WP5.9 & Twenty Twenty-Twoにしてみた


 

5.9から新しく導入されたサイトエディタ(ブロックエディタのサイト版のようなイメージ)を使ってみたくて、テーマを Twenty Twenty-Two に切り替えてみました。

ただテーマを適用してほんの少し調整しただけなんですけど、テーマの入れ替えだけでも気分転換になっていいですね 🙂

 

Twenty Twenty-Two のデフォルトで設定されているIndexのヘッダーのみにある、黒背景に飛んでいるきれいな鳥っぴーの画像、を変更しようと思い、私は沖縄に住んでいるので、ヤンバルクイナの画像にでもしようかなぁ、いや、ヤンバルクイナは飛べないや。。じゃぁ走っているような画像にしようかな。。。いやいや、そもそもWordPressとかプラグインめっちゃ関係ないし。。。 :mrgreen:

結局、私がブロックエディタにもまだ慣れていなくて、どこで画像を変更するのか見つけきれませんでした。。。 
まぁ、、今度考えようかな。

 

ところで、新機能のサイトエディタでカスタマイズした後、どうやっても「保存に失敗しました」の結果ばかりでした。 🙄 

調べてみると、Ajax経由でサイトエディタの保存結果を取得しているみたいなので、その結果を見ると 403 error。

ん?500エラーではなくて 403エラーなの?PHPのエラーではないのか。
と思い詳しく見てみると、lolipop の 403エラー画面案内が出ていました。(このサイトはlolipop使っているのでそのエラー画面です)

なるほどー、おそらくロリポップサーバの WAF の影響で 403エラーになっているのかなと思い、管理画面から WAF を無効に設定変更して、5分ほど放置。

その後、サイトエディタで保存をおこなうと、無事に保存されました。 🙂 

今までクラシックエディタでブログ更新していましたが、ブロックエディタを使っていればもっと早くに気づけたかもしれないですね。

 

ちょっと手間ですが、セキュリティ対策の能力が落ちたままはよくないので、あとでまたWAFを有効にします。 🙂 

 

あと、コンソール画面にめっちゃ WebSocket エラーが多発しますね。
ってか、WebSocketってfirebase とか nodejs とかでずっと接続するものに使われているものだよね?なんでWebSocketエラー?? 

とりあえず、このエラーはSSL対応のサイトになったら解決しそうな気がするな~ 🙄 

さすがにそろそろSSL対応のサイト、引っ越しを考えないといけないな~。これも今度考えよう。。。

 

う~ん、今度考えることが、ちょっと増えちゃった 😳 

 


コメントを残す